Selasa, 01 Mei 2012

Jaringan komputer edisi 6


VLAN(Virtual Local Area Network)

Kinerja sebuah jaringan sangat dibutuhkan oleh organisasi terutama dalam hal kecepatan dalam pengiriman data. Salah satu kontribusi teknologi untuk meningkatkan kinerja jaringan adalah dengan kemampuan untuk membagi sebuah broadcast domain yang besar menjadi beberapa broadcast domain yang lebih kecil dengan menggunakan VLAN. Broadcast domain yang lebih kecil akan membatasi device yang terlibat dalam aktivitas broadcast dan membagi device ke dalam beberapa grup berdasar fungsinya, se[erti layanan databasse untuk unit akuntansi, dan data transfer yang cepat untuk unit teknik.
Teknologi VLAN (Virtual Local Area Network) bekerja dengan cara melakukan pembagian network secara logika ke dalam beberapa subnet. VLAN adalah kelompok device dalam sebuah LAN yang dikonfigurasi (menggunakan software manajemen) sehingga mereka dapat saling berkomunikasi asalkan dihubungkan dengan jaringan yang sama walaupun secara fisikal mereka berada pada segmen LAN yang berbeda. Jadi VLAN dibuat bukan berdasarkan koneksi fisikal namun lebih pada koneksi logikal, yang tentunya lebih fleksibel. Secara logika, VLAN membagi jaringan ke dalam beberapa subnetwork. VLAN mengijinkan banyak subnet dalam jaringan yang menggunakan switch yang sama.
Dengan menggunakan VLAN, kita dapat melakukan segmentasi jaringan switch berbasis pada fungsi, departemen atau pun tim proyek. Kita dapat juga mengelola jaringan kita sejalan dengan kebutuhan pertumbuhan perusahaan sehingga para pekerja dapat mengakses segmen jaringan yang sama walaupun berada dalam lokasi yang berbeda.
Contoh penerapan teknologi VLAN diberikan dalam Gambar 1.
Gambar 1. Contoh penerapan teknologi VLAN.

Keunggulan VLAN
antara lain :
a.       Security
Keamanan data dari setiap divisi dapat dibuat tersendiri, karena segmennya bisa dipisah secara logika. Lalu lintas data dibatasi segmennya.
b.      Cost reduction
Penghematan dari penggunaan bandwidth yang ada dan dari upgrade perluasan network yang bisa jadi mahal.
c.       Higher performance
Pembagian jaringan layer 2 ke dalam beberapa kelompok broadcast domain yang lebih kecil, yang tentunya akan mengurangi lalu lintas packet yang tidak dibutuhkan dalam jaringan.
d.      Broadcast storm mitigation
Pembagian jaringan ke dalam VLAN-VLAN akan mengurangi banyaknya device yang berpartisipasi dalam pembuatan broadcast storm. Hal ini terjadinya karena adanya pembatasan broadcast domain.
e.       Improved IT staff efficiency
VLAN memudahkan manajemen jaringan karena pengguna yang membutuhkan sumber daya yang dibutuhkan berbagi dalam segmen yang sama.
f.       Simpler project or application management
VLAN menggabungkan para pengguna jaringan dan peralatan jaringan untuk mendukung perusahaan dan menangani permasalahan kondisi geografis.

VLAN ID
Untuk memberi identitas sebuah VLAN digunakan nomor identitas VLAN. Digunakan untuk menandai VLAN yang terkait. Dua range VLAN ID sbb :
a.       Normal Range VLAN (1 – 1005)
-          Digunakan untuk jaringan skala kecil dan menengah.
-          Nomor ID 1002 s.d. 1005 dicadangkan untuk Token Ring dan FDDI VLAN. 
-          ID 1, 1002 - 1005 secara default sudah ada dan tidak dapat dihilangkan.
-          Konfigurasi disimpan di dalam file database VLAN, yaitu vlan.dat. file ini disimpan dalam memori flash milkik switch.
-          VLAN trunking protocol (VTP), yang membantu manaejemn VLAN, nanti dipelajari di bab 4, hanya dapat bekerja pada normal range VLAN dan menyimpannya dalam file database VLAN.
b.      Extended Range VLANs (1006 – 4094)
-          Memungkinkan service provider untuk memperluas infrastrukturnya kepada konsumen yang lebih banyak. Dibutuhkan untuk perusahaan skala besar yang membutuhkan jumlah VLAN lebih dari normal.
-          Memiliki fitur yang lebih sedikit dibandingakn VLAN normal range.
-          Disimpan dalam NVRAM (file running configuration).
-          VTP tidak bekerja di sini.

Terminologi di dalam VLAN
Berikut ini diberikan beberapa terminologi di dalam VLAN :
a.       VLAN Data
VLAN Data adalah VLAN yang dikonfigurasi hanya untuk membawa data-data yang digunakan oleh user. Dipisahkan dengan lalu lintas data suara atau pun manajemen switch. Seringkali disebut dengan VLAN pengguna, User VLAN.
b.      VLAN Default
Semua port switch pada awalnya menjadi anggota VLAN Default. VLAN Default untuk Switch Cisco adalah VLAN 1. VLAN 1 tidak dapat diberi nama dan tidak dapat dihapus.
c.       Native VLAN
Native VLAN dikeluarkan untuk port trunking 802.1Q. port trunking 802.1Q mendukung lalu lintas jaringan yang datang dari banyak VLAN (tagged traffic) sama baiknya dengan yang datang dari sebuah VLAN (untagged traffic). Port trunking 802.1Q menempatkan untagged traffic pada Native VLAN.
d.      VLAN Manajemen
VLAN Manajemen adalah VLAN yang dikonfigurasi untuk memanajemen switch. VLAN 1 akan bekerja sebagai Management VLAN jika kita tidak mendefinisikan VLAN khusus sebagai VLAN Manajemen. Kita dapat memberi IP address dan subnet mask pada VLAN Manajemen, sehingga switch dapat dikelola melalui HTTP, Telnet, SSH, atau  SNMP.
e.       VLAN Voice
VLAN yang dapat mendukung Voice over IP (VoIP). VLAN yang dikhusukan untuk komunikasi data suara.

Terdapat 3 tipe VLAN dalam konfigurasi, yaitu :
a.       Static VLAN
Port switch dikonfigurasi secara manual. Contoh konfigurasinya :
SwUtama#config Terminal
Enter configuration commands, one per line.  End with CNTL/Z.
SwUtama(config)#VLAN 10
SwUtama(config-vlan)#name VLAN_Mahasiswa
SwUtama(config-vlan)#exit
SwUtama(config)#Interface fastEthernet 0/2
SwUtama(config-if)#switchport mode access
SwUtama(config-if)#switchport access VLAN 10
     
b.      Dynamic VLAN
Mode ini digunakan secara luas di jaringan skala besar. Keanggotaan port Dynamic VLAN dibuat dengan menggunakan server khusu yang disebut VLAN Membership Policy Server (VMPS). Dengan menggunakan VMPS, kita dapat menandai port switch dengan VLAN? secara dinamis berdasar pada MAC Address sumber yang terhubung dengan port.

c.       Voice VLAN
Port dikonfigurasi dalam mode voice sehingga dapat mendukung IP phone yang terhubung. Contoh konfigurasinya :
SwUtama(config)#VLAN 120
SwUtama(config-vlan)#name VLAN_Voice
SwUtama(config-vlan)#exit
SwUtama(config)#Interface fastEthernet 0/3
SwUtama(config-if)#switchport voice VLAN 120

Berikut ini sedikit command untuk konfigurasi dasar VLAN pada Swicth Cisco Catalyst :
ð  Langkah 1: Membuat VLAN
(secara default, hanya ada satu VLAN, yaitu VLAN 1)
syntax
Switch#configure terminal
Switch(config)#vlan NomorVLAN
Switch(config-vlan)#name NamaVLAN
contoh: untukmembuat VLAN dengan ID nomor 10 nama marketing.
Switch#configure terminal
Switch(config)#vlan 10
Switch(config-vlan)#name marketing
Switch(config-vlan)#end

ð  Langkah 2: Verifikasi VLAN yang sudah dibuat:
Command:
Switch#sh vlan brief

ð  Langkah 3: Memasukkan Port menjadi anggota suatu VLAN
(secara default semua port dalam switch menjadi anggota VLAN 1)
Contoh: memasukkan Port Fa0/1 menjadi anggota VLAN 10:
Switch#configure terminal
Switch(config)#interface fa0/1
Switch(config-if)#switchport mode access
Switch(config-if)#switchport access vlan 10
Switch(config-if)#end
Jika Anda ingin memasukkan beberapa port bersama-sama menjadi anggota port 10, bisa juga menggunakan interface range. misal Anda ingin memasukkan port Fa0/1 sampai dengan Fa0/6, maka urutan perintahnya adalah:
Switch#configure terminal
Switch(config)#interface range fa0/1 - fa0/6
Switch(config-if-range)#switchport mode access
Switch(config-if-range)#switchport access vlan 10

ð  Langkah 4: Verifikasi Pengaturan Port Menjadi anggota VLAN
Switch#sh vlan brief
VLAN Name Status Ports
—- ——————————– ——— ——————————-
1 default active Fa0/7, Fa0/8, Fa0/9, Fa0/10
Fa0/11, Fa0/12, Fa0/13, Fa0/14
Fa0/15, Fa0/16, Fa0/17, Fa0/18
Fa0/19, Fa0/20, Fa0/21, Fa0/22
Fa0/23, Fa0/24, Gig1/1, Gig1/2
10 marketing active Fa0/1, Fa0/2, Fa0/3, Fa0/4
Fa0/5, Fa0/6
1002 fddi-default active
1003 token-ring-default active
1004 fddinet-default active
1005 trnet-default active

ð  Menghapus VLAN: Bila Anda Menghapus sebuah VLAN, Anda dapat menggunakan perintah “no vlan NomorVlan.
contoh: perintah untukmenghapus VLAN 10:
Switch#configure terminal
Switch(config)#no vlan 10

Intra-VLAN  adalah komunikasi antar host yang berada dalam VLAN ID yang sama dinamakan dengan.
Inter-VLAN  adalah komunikasi antar host dalam sebuah VLAN dengan host dalam VLAN yang lain dinamakan. Tentunya dalam komunikasi Inter-VLAN dibutuhkan sebuah Router karena mereka berbeda network.
Switch layer 3 dapat membuat route di antara VLAN-VLAN dengan menggunakan teknologi switch virtual interface (SVI). SVI merupakan interface (secara logika) yang dikonfigurasi untuk suatu VLAN. SVI perlu dikonfigurasi untuk membuat route antar VLAN atau untuk memberikan koneksi IP dengan host. Secara default, SVI dibuat untuk VLAN 1 sehingga bisa dikelola secara remote.
Sebuah VLAN Native ditandai dengan sebuah port trunk 802.1Q. Sebuah port trunk 802.1Q mendukung traffic dari banyak VLAN sama seperti traffic yang tidak berasal dari sebuah VLAN.  Trunk adalah link point-to point diantara satu atau lebih interface ethernet device jaringan seperti router atau switch. Trunk Ethernet membawa lalu lintas dari banyak VLAN melalui link tunggal. Sebuah VLAN trunk mengijinkan kita untuk memperluas VLAN melalui seluruh jaringan. Jadi link Trunk digunakan untuk menghubungkan antar device intermediate. Dengan menggunakan port trunk, dapat digunakan sebuah link fisik untuk menghubungkan banyak VLAN.
Sebuah Port pada Switch Cisco Catalyst mempunyai beberapa mode trunk. Mode trunking tersebut didefinisikan untuk negosiasi antar port yang saling berhubungan dengan menggunakan Dynamic Trunking Protocol (DTP). DTP merupakan sebuah protokol keluaran Cisco. Switch dari vendor lain tidak mendukung DTP. DTP mengatur negosiasi mode trunk hanya jika port switch dikonfigurasi dalam mode trunk yang mendukung DTP. DTP mendukung baik ISL maupun 802.1Q.  Ada tiga mode trunk pada DTP, yaitu: Trunk, Access, Dynamic Auto dan Dynamic Desirable. 
Berikut ini diberikan contoh perintah untuk konfigurasi trunking pada port Fa0/1 sebuah switch :
Switch#configure terminal
Switch(config)#interface fa0/1
Switch(config-if)#switchport mode trunk
Switch(config-if)#end

Tipe Tipe VLAN
Keanggotaan dalam suatu VLAN dapat di klasifikasikan berdasarkan port yang di gunakan, MAC address, tipe protokol. Berikut keterangan masing-masingnya :
ð  Berdasarkan Port
Keanggotaan   pada  suatu   VLAN   dapat   di   dasarkan   pada  port   yang   di   gunakan   oleh   VLAN tersebut.   Sebagai   contoh,   pada   bridge/switch  dengan   4   port,   port   1,   2,   dan   4   merupakan VLAN 1 sedang port 3 dimiliki oleh VLAN 2. Tabel port dan VLAN :
Port                 1 2 3 4
VLAN             2 2 1 2
Kelemahannya adalah user tidak bisa untuk berpindah pindah, apabila harus berpindah maka network administrator harus mengkonfigurasikan ulang.

ð  Berdasarkan MAC Address
Keanggotaan suatu VLAN didasarkan pada MAC  address dari setiap workstation/komputer yang dimiliki oleh user. Switch mendeteksi/mencatat semua MAC address yang dimiliki oleh setiap Virtual LAN. MAC address merupakan suatu bagian yang dimiliki oleh NIC (Network Interface Card) di setiap workstation.
Kelebihannya   apabila   user   berpindah   pindah    maka   dia   akan  tetap   terkonfigurasi   sebagai anggota     dari  VLAN     tersebut.Sedangkan      kekurangannya     bahwa    setiap   mesin   harus   dikonfigurasikan secara manual , dan untuk jaringan yang memiliki ratusan workstation maka tipe ini kurang efissien untuk dilakukan. Tabel MAC address dan VLAN :
MAC address              132516617738 272389579355 536666337777 24444125556
VLAN                                     1                        2                                2                     1

ð  Berdasarkan tipe protokol yang digunakan
Keanggotaan VLAN juga bisa berdasarkan protocol yang digunakan.Tabel Protokol dan VLAN :
Protokol         IP      IPX
VLAN             1       2

ð  Berdasarkan Alamat Subnet IP
Subnet IP address pada suatu jaringan juga dapat digunakan untuk mengklasifikasi suatu VLAN. Tabel IP Subnet dan VLAN :
IP subnet        22.3.24         46.20.45
VLAN               1                         2
Konfigurasi      ini  tidak   berhubungan     dengan     routing   pada    jaringan   dan   juga   tidak mempermasalahkan funggsi   router.  IP  address   digunakan   untuk   memetakan   keanggotaan VLAN.      Keuntungannya      seorang    user  tidak  perlu  mengkonfigurasikan       ulang  alamatnya di   jaringan   apabila  berpindah    tempat,   hanya   saja  karena   bekerja   di  layer  yang   lebih tinggi   maka   akan   sedikit   lebih   lambat   untuk   meneruskan   paket   di   banding   menggunakan MAC addresses.

ð  Berdasarkan aplikasi atau kombinasi lain
Sangat dimungkinkan untuk menentukan suatu VLAN berdasarkan aplikasi yang dijalankan, atau   kombinasi   dari   semua   tipe   di   atas   untuk   diterapkan   pada   suatu   jaringan.   Misalkan:  aplikasi  FTP (file  transfer protocol)   hanya  bisa digunakan   oleh   VLAN  1 dan   Telnet hanya bisa digunakan pada VLAN 2.


(Untuk file lengkap ekstensi docx, silahkan lihat pada menu download "VLAN(virtual local area network)")

Sumber :
PENS-ITS,Telecommunication departements. Pratikum jaringan komputer 2.
ICNE, Network Tech Support. Modul 27. Virtual LAN (VLAN).

Tidak ada komentar:

Poskan Komentar